Old Adobe Installation

We are currently running CC2018 in the labs. If you have already updated to CC2019 apps, you will need to download the older version to be compatible with the version in the lab - Premiere 12.1.2.

Old Adobe Installation

We are currently running CC2018 in the labs. If you have already updated to CC2019 apps, you will need to download the older versions to be compatible with the lab versions.